



<!DOCTYPE html>
<html lang="en" prefix="og: https://ogp.me/ns#">
<head>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-Y8FQYHZ5SK"></script>
<script>
	window.dataLayer = window.dataLayer || [];
	function gtag()
	gtag('js', new Date());
	gtag('config', 'G-Y8FQYHZ5SK');
</script>




<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-T24HWP4');</script>
<!-- End Google Tag Manager -->

    
    
    
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta name="msapplication-config" content="https://static.blogto.com/static/img/favicon/browserconfig.xml"/>
    <meta http-equiv="x-ua-compatible" content="IE=edge">
    <link rel="alternate" type="application/atom+xml" title='blogTO RSS Feed' href="http://feeds.feedburner.com/blogto">
    <meta name="format-detection" content="telephone=no">

    
    
        <link rel="apple-touch-icon" type="image/png" href="https://static.blogto.com/static/img/favicon/apple-touch-icon.png">
    

    
        <link rel="icon" type="image/png" href="https://static.blogto.com/static/img/favicon/favicon-16x16.png" sizes="16x16">
    

    
        <link rel="icon" type="image/png" href="https://static.blogto.com/static/img/favicon/favicon-32x32.png" sizes="32x32">
    

    
        <link rel="shortcut icon" href="https://static.blogto.com/static/img/favicon/android-chrome-192x192.png" sizes="192x192">
    

    
    <title>Police busted an illegal car meet-up in Oshawa with more than 300 people</title>
    <meta name="google-site-verification" content="OnajU0JqaR7GbNn36tIGLItHoCVGBMuABazvl0YTfjY"/>
    <meta name="description" content="You know lockdown is easing up and things are getting back to normal when the GTA car bros start congregating for meetups again — and yes, it's alr..." />
    
	    <meta name="keywords" content="car,meet,illegal,gathering,oshawa,durham,region,police,news,ontario" />
    
    <link rel="canonical" href="https://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/" />
    <meta property="fb:app_id" content="100616073343311"/>
    <meta property="fb:pages" content="30843680008" />
    <meta property="og:site_name" content="blogTO" />
    <meta property="og:url" content="https://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"/>
    <meta property="og:title" content="Police busted an illegal car meet-up in Oshawa with more than 300 people" />
    <meta property="og:image" content="https://media.blogto.com/articles/20210311-carmeet2.jpg?w=1200&cmd=resize_then_crop&height=630&quality=70"/>
    
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />

    <meta property="og:description" content="You know lockdown is easing up and things are getting back to normal when the GTA car bros start congregating for meetups again — and yes, it's alr...">
    <meta property="og:type" content="article"/>
    
    <meta name="twitter:card" content="summary_large_image"/>
    <meta name="twitter:site" content="@blogTO"/>

    
      <meta name="apple-itunes-app" content="app-id=1393143157">
    
    

    
    <meta name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1">




    
    <link type="text/css" href="https://static.blogto.com/static/dist/blogto-app-dd448baf0cb23dba758986b7f3210e26.css" rel="stylesheet" />

    


    <script src="//cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js"></script>
    
<!--[if lt IE 9]>
<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
<![endif]-->




    
    <script>

        var _gaq = _gaq || [];
        _gaq.push(['_setAccount', 'UA-220979-1']);
        _gaq.push(['_trackPageview']);
        (function () {
            var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
            ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
            var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
        })();

    </script>
    <script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
    <script type="text/javascript">
    var _sf_async_config={uid:40495,domain:"blogto.com",useCanonical:true};
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
         loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();

    </script>
    <script type='text/javascript'>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function () {
            var gads = document.createElement('script');
            gads.async = true;
            gads.type = 'text/javascript';
            var useSSL = 'https:' == document.location.protocol;
            gads.src = (useSSL ? 'https:' : 'http:') +
                    '//www.googletagservices.com/tag/js/gpt.js';
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(gads, node);
        })();
    </script>

    <script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
    </script>
    <script type='text/javascript'>
    GS_googleAddAdSenseService("ca-pub-3265858257515661");
    GS_googleEnableAllServices();
    </script>

    <!-- Begin comScore Tag -->
    <script>
      document.write(unescape("%3Cscript src='" +
    (document.location.protocol == "https:" ? "https://sb" : "https://b") +
    ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
    </script>
    <script>
    COMSCORE.beacon({
      c1:2,
      c2:7517117,
      c3:"",
      c4:"",
      c5:"",
      c6:"",
      c15:""
    });
    </script>
    <noscript>
        <img src="https://b.scorecardresearch.com/p?c1=2&c2=7517117&c3=&c4=&c5=&c6=&c15=&cj=1"/>
    </noscript>

    
    <script type="text/javascript">
        window.freshDaily = {
            "initializers": [],
            "preProcessors": [],
            "deferredAdvertMap": {},
            "advertMap": {},
            "staticRoot": "https://static.blogto.com/static/",
            "mediaRoot": "https://static.blogto.com/"
        };
    </script>

    <script>
        function onRelatedVideoPlay(videoId, youtubeCode) {
            const previouslyOpenedVideos = Array.from(document.querySelectorAll(".related-video"));

            previouslyOpenedVideos.map(video => {
              const youtubeIframe = video.querySelectorAll("iframe");

              if (youtubeIframe) {
                video.querySelectorAll(".related-video-wrapper")[0].innerHTML = "";
                video.className = "related-video";
              }
            });

            if (youtubeCode) {
                const customPlayVideoEvent = new CustomEvent("playButtonClick");

                window.dispatchEvent(customPlayVideoEvent);

                document.querySelectorAll(`.related-video[data-video-id="${videoId}"]`)[0].className += " video-active";
                document.querySelectorAll(`.related-video[data-video-id="${videoId}"] .related-video-wrapper`)[0].innerHTML =
                    `<iframe width="337"
                             height="337"
                             src="https://www.youtube.com/embed/${youtubeCode}?autoplay=1&rel=0"
                             frameBorder="0"
                             controls="0"
                             allow="autoplay"
                             allowFullScreen/>`;
            }
        }
    </script>

    <script>
      function sleep(ms) {
          return new Promise(resolve => setTimeout(resolve, ms));
      }
    </script>

    <script>
        function kebabCaseToCamelCase(string) {
          return string.replace(/-([a-z])/g, function (g) { return g[1].toUpperCase(); });
        }
    </script>

    <!-- Facebook Pixel Code -->
    <script>
      !function(f,b,e,v,n,t,s)
      {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
        n.callMethod.apply(n,arguments):n.queue.push(arguments)};
        if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
        n.queue=[];t=b.createElement(e);t.async=!0;
        t.src=v;s=b.getElementsByTagName(e)[0];
        s.parentNode.insertBefore(t,s)}(window,document,'script',
        'https://connect.facebook.net/en_US/fbevents.js');
      fbq('init', '1129511487248605');
      fbq('track', 'PageView');
    </script>
    <noscript>
        <img height="1" width="1"
             src="https://www.facebook.com/tr?id=1129511487248605&ev=PageView&noscript=1"/>
    </noscript>
    <!-- End Facebook Pixel Code -->
</head>
<body class="site blogto 
article-detail-page rich-content-page 
"
      style="
">


    <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-T24HWP4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    
    <header class="nav-bar-container">
    <nav class="nav-bar">
        <div class="nav-bar-logo">
            <a class="nav-bar-logo-link" href="/"></a>
        </div>
        <div class="nav-bar-content">
            <div class="nav-bar-menu-container">
                <div class="nav-bar-menu not-visible">
                    <button class="nav-bar-menu-close-button"></button>
                    <ul class="nav-bar-menu-item-list">
                        <li class="nav-bar-menu-item nav-bar-menu-home-item">
                            <a class="nav-bar-menu-item-link"
                               href="/">Home</a></li>
                    
                        
                        <li class="nav-bar-menu-item nav-bar-menu-best-of-item selected">
                            <a class="nav-bar-menu-item-link"
                               href="/toronto">Best Of Toronto</a>
                        </li>
                        
                        
                        <li class="nav-bar-menu-item nav-bar-menu-videos-item">
                            <a class="nav-bar-menu-item-link"
                               href="/videos">Videos</a>
                        </li>
                        
                        
                            
                        
                        
                        <li class="nav-bar-menu-item nav-bar-menu-contests-item">
                            <a class="nav-bar-menu-item-link"
                               href="/contests">Contests</a></li>
                        
                        
                        <li class="nav-bar-menu-item nav-bar-menu-patio-guide-item">
                            <a class="nav-bar-menu-item-link"
                               href="http://patios.blogto.com/">Patio Guide</a>
                        </li>
                        
                        
                        <li class="nav-bar-menu-restaurants-item nav-bar-menu-item">
                            <a class="nav-bar-menu-item-link"
                               href="/restaurants">Restaurants</a>
                        </li>
                        
                        <li class="nav-bar-menu-latest-news-item nav-bar-menu-item"><span
                                class="nav-bar-menu-item-link">Latest News</span>
                        </li>
                        
                        <li class="nav-bar-menu-places-item nav-bar-menu-item"><span
                                class="nav-bar-menu-item-link">Places</span>
                        </li>
                        
                        
                        <li class="nav-bar-menu-more-item nav-bar-menu-item"><span
                                class="nav-bar-menu-item-label">More</span>
                        </li>
                        
                    
                    </ul>
                </div>
            </div>
        </div>
    </nav>
    <script type="text/javascript">
        (function () {
            document.body.classList.add("nav-bar-body");
        })();
    </script>
</header>






<div class="page-takeover-container">
    
    
        <div id="1029532/blogTOcitytakeover1600x700"
             class="advert"
             style="min-height: 700px">
            <script type='text/javascript'>
                (function () {
                    var advert = {};
                    var screenTypes = [];
                    advert.id = "1029532/blogTOcitytakeover1600x700";
                    advert.elementId = "1029532/blogTOcitytakeover1600x700";
                    advert.width = 1600;
                    advert.height = 700;
                    advert.boxType = "page_takeover";
                    
                        screenTypes.push("large");
                    
                    advert.screenTypes = screenTypes;

                    window.freshDaily.advertMap[advert.boxType] = advert;

                    window.freshDaily.preProcessors.push(function () {
                        window.freshDaily.AdvertManager.initAdvert(advert, googletag);
                    });
                })();
            </script>
        </div>
    


</div>


<div class="site-advert-top-container horizontal-advert-container">
    <div class="site-advert-top">
        
    
        <div id="1029532/blogTOcitytakeover728x90pos2"
             class="advert"
             style="min-height: 90px">
            <script type='text/javascript'>
                (function () {
                    var advert = {};
                    var screenTypes = [];
                    advert.id = "1029532/blogTOcitytakeover728x90pos2";
                    advert.elementId = "1029532/blogTOcitytakeover728x90pos2";
                    advert.width = 728;
                    advert.height = 90;
                    advert.boxType = "first_horizontal";
                    
                        screenTypes.push("medium");
                    
                        screenTypes.push("large");
                    
                    advert.screenTypes = screenTypes;

                    window.freshDaily.advertMap[advert.boxType] = advert;

                    window.freshDaily.preProcessors.push(function () {
                        window.freshDaily.AdvertManager.initAdvert(advert, googletag);
                    });
                })();
            </script>
        </div>
    


    </div>
</div>


<div class="base-site-content">
    



<div class="rich-content-heading rich-content-heading-main ">
    <div class="rich-content-heading-wrapper">
        <div class="rich-content-meta">
            <div class="rich-content-meta-content">
                <div class="rich-content-category">
                    <a href="/city/">City</a>
                </div>

                
                

                <div class="rich-content-info">
                    <div class="rich-content-author">
                        
                        <span>Becky Robertson</span>
                    </div>

                

                    <div class="rich-content-post-date">
                        <span class="rich-content-post-label">
                            Posted
                        </span>
                        <span class="rich-content-post-date-timeago"
                              title="2021-03-11T17:37:41">
                                an hour ago
                        </span>
                    </div>
                </div>
            </div>
            <div class="rich-content-meta-report">
                <span class="rich-content-meta-report-label">
                    <a href="mailto:editors@blogto.com?subject=Inaccurate Information about Police busted an illegal car meet-up in Oshawa with more than 300 people&body=There is inaccurate content on this page:%0D%0A%0D%0Ahttps://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"
                       class="rich-content-meta-report-link">Report Inaccuracy</a>
                </span>
            </div>
        </div>
    </div>
</div>


<section class="article-detail-lead-section">
    

<div class="article-lead no-animation">
    <div class="article-lead-picture-container">
        <div class="article-lead-picture-wrapper">
            <div class="article-lead-picture-wrapper-content">
                
                    <picture class="article-lead-picture">
                        <img src="https://media.blogto.com/articles/20210311-carmeet2.jpg?w=2048&cmd=resize_then_crop&height=1365&quality=70"
                             class="article-lead-image"
                             alt="car meet"/>

                        
                    </picture>
                
            </div>
        </div>

        <div class="round-controls-container"
             data-share-url="http://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"
             data-article-id="105822">
        </div>
    </div>

    <p class="article-lead-title">
        <span class="article-lead-title-text highlighted-text">
            Police busted an illegal car meet-up in Oshawa with more than 300 people
        </span>
    </p>
</div>

</section>


<div class="rich-content-heading rich-content-heading-sub ">
    <div class="rich-content-heading-wrapper">
        <div class="rich-content-meta">
            <div class="rich-content-meta-content">
                <div class="rich-content-category">
                    <a href="/city/">City</a>
                </div>

                
                

                <div class="rich-content-info">
                    <div class="rich-content-author">
                        
                        <span>Becky Robertson</span>
                    </div>

                

                    <div class="rich-content-post-date">
                        <span class="rich-content-post-label">
                            Posted
                        </span>
                        <span class="rich-content-post-date-timeago"
                              title="2021-03-11T17:37:41">
                                an hour ago
                        </span>
                    </div>
                </div>
            </div>
            <div class="rich-content-meta-report">
                <span class="rich-content-meta-report-label">
                    <a href="mailto:editors@blogto.com?subject=Inaccurate Information about Police busted an illegal car meet-up in Oshawa with more than 300 people&body=There is inaccurate content on this page:%0D%0A%0D%0Ahttps://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"
                       class="rich-content-meta-report-link">Report Inaccuracy</a>
                </span>
            </div>
        </div>
    </div>
</div>


<section class="article-detail-body-section rich-content-section">

    <div class="article-detail-sidebar rich-content-sidebar">
        <div id="article-detail-sticky-side-content">
            <div class="article-detail-square-advert-wrapper">
                
    
        <div id="1029532/blogTOCity300x250top"
             class="advert"
             style="min-height: 250px">
            <script type='text/javascript'>
                (function () {
                    var advert = {};
                    var screenTypes = [];
                    advert.id = "1029532/blogTOCity300x250top";
                    advert.elementId = "1029532/blogTOCity300x250top";
                    advert.width = 300;
                    advert.height = 250;
                    advert.boxType = "article_detail_square";
                    
                        screenTypes.push("large");
                    
                    advert.screenTypes = screenTypes;

                    window.freshDaily.advertMap[advert.boxType] = advert;

                    window.freshDaily.preProcessors.push(function () {
                        window.freshDaily.AdvertManager.initAdvert(advert, googletag);
                    });
                })();
            </script>
        </div>
    


            </div>
            
                
                    <div class="newsletter-subscribe-panel newsletter-subscribe-panel-plain">
    <div class="newsletter-subscribe-panel-heading">
        <h4 class="newsletter-subscribe-panel-title">Stay in the loop</h4>
        <span class="newsletter-subscribe-panel-message">Sign up for our free email newsletter. Unsubscribe anytime or <a href="/contact/" target="_blank">contact us</a> for details.</span>
    </div>

    <div class="newsletter-subscribe-form-container">
        <div class="newsletter-subscribe-form-wrapper">
        </div>
    </div>
</div>


                    <div id="article-detail-sidebar-solid-controls-container"
     class=" article-solid-controls-container solid-controls-container">

    <script type="text/javascript">
        (function(){
            var articleId = parseInt("105822", 10);
            var articleShareUrl = "https://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/";
            window.freshDaily.initializers.push(function (store) {

                var containerId = "#article-detail-sidebar-solid-controls-container";

                window.freshDaily.initArticleSolidControls(containerId, store, {
                    shareUrl: articleShareUrl,
                    articleId:articleId
                });
            });
        })();
    </script>
</div>
                
            
        </div>
    </div>

    <div class="article-detail-body ">
        <div class="article-detail-content-wrapper rich-content-wrapper">
            <div class="rich-content">
                <p>You know lockdown is easing up and things are getting back to normal when the <a href="https://www.blogto.com/city/2020/09/wasaga-beach-car-rally/">GTA car bros</a> start congregating for meetups again — and yes, it's already happening.</p>

<p>(GTA here meaning Greater Toronto Area, not Grand Theft Auto, though the confusion is understandable.)</p>

<p>Durham police had to bust up a large gathering in a parking lot in Oshawa around 8:30 p.m. on Wednesday near the intersection of Taunton and Harmony Roads, and discovered upon arrival that no, it wasn't just a swarm of people eager to get their shop on at the plaza's Mark's or La Vie en Rose.</p>

<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Just stupid and irresponsible</p>
— RamkissS (@RamkissS) <a href="https://twitter.com/RamkissS/status/1370013266567630852?ref_src=twsrc%5Etfw">March 11, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

<p>It was one of suburban Southern Ontario's famous car meets, in which a whole bunch of <a href="https://www.blogto.com/city/2020/09/doug-ford-street-racing-yahoos-1000-person-ancaster-car-rally/">yahoos</a> gather to admire each other's modded cars, show off their own, and <a href="https://www.blogto.com/city/2020/05/toronto-police-bust-illegal-fast-and-furious-style-street-racing-meetup/">perhaps even race</a> and get up to <a href="https://www.blogto.com/city/2020/05/toronto-stunt-driver-victoria-day-donuts-fireworks/">other ill-advised antics</a>.</p>

<p>Unfortunately for those in attendance, Durham Region is currently in the red zone of <a href="https://www.blogto.com/city/2020/05/toronto-stunt-driver-victoria-day-donuts-fireworks/">the province's reopening framework</a>, meaning that private social gatherings are limited to 25 people outdoors, and only five indoors.</p>

<p>In this case, the party was well over 25 people — <a href="https://torontosun.com/news/local-news/crowd-of-300-reported-at-oshawa-plaza-for-car-meet-up?utm_term=Autofeed&amp;utm_medium=Social&amp;utm_source=Twitter#Echobox=1615490532">more than 300</a>, in fact.</p>

<p>No arrests were made, though it is unclear if the cops decided to issue any tickets for violating the Reopening Ontario Act, which they definitely could have. </p>

<blockquote class="twitter-tweet" data-conversation="none">
<p dir="ltr" lang="en">I live in the area. They were very loud! Then the helicopter! Kept my children awake 😔 we are still battling high covid numbers. I hope tickets were issued!</p>
— Paula Drinkle (@pmdrinkle) <a href="https://twitter.com/pmdrinkle/status/1370019776991481858?ref_src=twsrc%5Etfw">March 11, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

<p><a href="http://www.blogto.com/city/2020/09/police-tickets-wasaga-beach-car-rally/">In similar incidents</a>, for whatever reason, law enforcement has not been very harsh with punishing those who choose to ignore provincial orders — though it's clear this meetup, like many others, annoyed the hell out of locals nearby.</p>


            </div>

        

            
            
            

            <div class="secondary-rich-content rich-content">
                
            </div>

            
            <div class="article-lead-photographer rich-content-lead-photographer">
                <span class="lead-photographer-label">Lead photo by </span>
                <span class="lead-photographer-value">
                    <p><a href="https://www.facebook.com/OfficialDRPS/photos/3712047938893850">Durham Regional Police</a></p>
                </span>
            </div>
            

            <div id="article-detail-content-solid-controls-container"
     class=" rich-content-solid-controls-container  article-solid-controls-container solid-controls-container">

    <script type="text/javascript">
        (function(){
            var articleId = parseInt("105822", 10);
            var articleShareUrl = "https://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/";
            window.freshDaily.initializers.push(function (store) {

                var containerId = "#article-detail-content-solid-controls-container";

                window.freshDaily.initArticleSolidControls(containerId, store, {
                    shareUrl: articleShareUrl,
                    articleId:articleId
                });
            });
        })();
    </script>
</div>
        </div>

        <hr id="article-detail-sticky-side-content-bottom-limit" class="rich-content-thinrule thinrule">

        <div id="article-detail-plain-controls-container" class="plain-controls-container">

    <script type="text/javascript">
        window.freshDaily.initializers.push(function (store) {
            var containerId = "#article-detail-plain-controls-container";
            var articleId = parseInt("105822", 10);
            var articleShareUrl = "http://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/";

            window.freshDaily.initArticlePlainControls(containerId, store, {
                articleId: articleId,
                shareUrl: articleShareUrl
            });
        });
    </script>
</div>

        <p class="fb-comments-loader">
            <span class="fb-comments-loader-label">Join the conversation</span>
            <a class="fb-comments-loader-link"
               href="#article-detail-fb-comments-wrapper"
               role="button">
                <span>Load </span>
                <span class="fb-comments-count"
                      
                      data-href="http://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"></span>
                <span> comments</span>
            </a>
        </p>
    </div>
</section>



<div class="email-newsletter-dialog not-visible"></div>

<section class="social-section">
    <div class="article-detail-newsletter-container newsletter-container">
        
        <div class="newsletter-subscribe-panel newsletter-subscribe-panel-large">
    <div class="newsletter-subscribe-panel-heading">
        <h4 class="newsletter-subscribe-panel-title">Stay in the loop</h4>
        <span class="newsletter-subscribe-panel-message">Sign up for our free email newsletter so you’re always in the know. You can unsubscribe anytime or <a href="/contact/" target="_blank">contact us</a> for details.</span>
    </div>

    <div class="newsletter-subscribe-form-container">
        <div class="newsletter-subscribe-form-wrapper">
        </div>
    </div>
</div>

        
    </div>

    <div class="fb-comments-row">
        <div class="fb-comments-container">
            <div id="article-detail-fb-comments-wrapper" class="fb-comments-wrapper">
                <div class="fb-comments"
  data-href="http://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"
  data-width="100%"
  data-numposts="4"></div>

            </div>
            <div class="fb-page-box-container">
                <div class="fb-page"
    data-href="https://www.facebook.com/blogto"
    data-width="300"
    data-small-header="false"
    data-adapt-container-width="true"
    data-hide-cover="false"
    data-show-facepile="true">
    <div class="fb-xfbml-parse-ignore">
      
    </div>
</div>

            </div>
        </div>
    </div>
</section>




<section class="article-detail-latest-articles-section">
    <div class="article-detail-latest-articles-content">
        <h2 class="article-detail-latest-articles-title">
            <span class="article-detail-latest-articles-title-text">
                Latest in City
            </span>
        </h2>

        <div class="static-article-thumbnail-grid-container article-thumbnail-grid-container">
            <div class="article-thumbnail-grid blogto-grid">
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20210311-shoppers-vaccine-1.jpg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105823"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/people-toronto-lines-shoppers-vaccines/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Huge lineups form outside Shopper&#39;s Drug Mart in Toronto as people try to get vaccine
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20210311-carmeet2.jpg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105822"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Police busted an illegal car meet-up in Oshawa with more than 300 people
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20210311-the-toronto-zoo.png?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105821"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/toronto-zoo-video-orangutan-mates-couple-goals/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Toronto Zoo releases adorable video of orangutan mates and they&#39;re couple goals
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20210311-when-is-daylight-savings-time-in-ontario.jpg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105814"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/clocks-spring-forward-ontario-weekend-bill-get-rid-time-changes/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Clocks to spring forward in Ontario this weekend despite bill to get rid of time changes
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20201022-dufferin-mall-toronto-2.jpg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105810"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/mayor-tory-responds-viral-video-people-asking-toronto-build-move-theatre-dufferin-mall/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Mayor Tory responds to funny viral video calling for a movie theatre in Dufferin Mall
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20210311-classactionsettlementontario.jpg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105801"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/class-action-lawsuit-gift-card-ontario/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            You could be owed more than $100 as part of a class action gift card lawsuit in Ontario
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/202103211-antimaskvideo2.jpg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105811"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/anti-masker-toronto-store-fighting-employees/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Anti-masker films herself entering Toronto store maskless and fighting with staff
        </span>
    </p>
</div>
                </div>
                
                <div class="article-thumbnail-grid-item blogto-grid-item">
                    



<div class="article-thumbnail">
    

    <div class="article-thumbnail-picture-container">
        <div class="article-thumbnail-picture-wrapper">
            <div class="article-thumbnail-picture">
                
                    <img src="https://media.blogto.com/articles/20210311-etobicoke-creek.jpeg?w=720&amp;cmd=resize_then_crop&amp;height=480&amp;quality=70"
                         class="article-thumbnail-image"/>
                
            </div>

            
        </div>

        
            <div class="round-controls-container"
                 data-article-id="105808"
                 data-object-type="article">
            </div>
        
    </div>

    <a href="/city/2021/03/almost-all-torontos-river-water-contaminated-road-salts-even-during-summer/"
       class="article-thumbnail-link">
    </a>

    <p class="article-thumbnail-title">
        <span class="article-thumbnail-title-text highlighted-text">
            Almost all of Toronto&#39;s river water is contaminated with road salts even during summer
        </span>
    </p>
</div>
                </div>
                
            </div>
        </div>

        <div id="root-latest-articles"></div>
    </div>
</section>

<script type="text/javascript">
    (function () {
        window.freshDaily.customArticleDetailPageReducerGenerators = [];
    })();
</script>


<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.blogto.com/city/2021/03/oshawa-police-bust-huge-car-meetup-toronto/"
  },
  "headline": "Police busted an illegal car meet-up in Oshawa with more than 300 people",
  "image": [
    "https://media.blogto.com/articles/20210311-carmeet2.jpg?w=1200&amp;cmd=resize_then_crop&amp;height=630&amp;quality=70"
   ],
  "datePublished": "2021-03-11 17:37",
  "author": {
    "@type": "Person",
    "name": "Becky Robertson"
  },
   "publisher": {
    "@type": "Organization",
    "name": "blogTO",
    "logo": {
      "@type": "ImageObject",
      
      "url": "https://static.blogto.com/static/img/logo/blogto-kp.jpg"
      
    }
  }
}
</script>




    <iframe class="firefox-tracking-protection-detector"
            src="//googlesyndication.com"
            onload="window.isFirefoxTPDisabled = true"></iframe>
</div>

<div id="fb-root"></div>



<footer class="footer-container">
    <nav id="footer">
        <div class="social">
            
            <a class="footer-social-link facebook-link" href="https://www.facebook.com/blogto">
                <img class="footer-social-icon"
                     src="https://static.blogto.com/static/img/icons/social/facebook-darkgrey-36.svg">
            </a>
            
            
            <a class="footer-social-link twitter-link" href="https://twitter.com/blogTO">
                <img class="footer-social-icon"
                     src="https://static.blogto.com/static/img/icons/social/twitter-darkgrey-36.svg">
            </a>
            
            
            <a class="footer-social-link instagram-link" href="https://www.instagram.com/blogto/">
                <img class="footer-social-icon footer-instagram-icon"
                     src="https://static.blogto.com/static/img/icons/social/instagram-darkgrey-36.svg">
            </a>
            
            
            <a class="footer-social-link tiktok-link" href="https://www.tiktok.com/@blogto">
                <img class="footer-social-icon"
                     src="https://static.blogto.com/static/img/icons/social/tiktok-darkgrey-36.svg">
            </a>
            
            
            <a class="footer-social-link youtube-link" href="https://www.youtube.com/blogto">
                <img class="footer-social-icon"
                     src="https://static.blogto.com/static/img/icons/social/youtube-darkgrey-36.svg">
            </a>
            
            
            <a class="footer-social-link flickr-link" href="https://www.flickr.com/groups/blogto/">
                <img class="footer-social-icon"
                     src="https://static.blogto.com/static/img/icons/social/flickr-darkgrey-36.svg">
            </a>
            
            
            <a class="footer-social-link rss-link" href="http://feeds.feedburner.com/blogto/">
                <img class="footer-social-icon"
                     src="https://static.blogto.com/static/img/icons/social/rss-darkgrey-36.svg">
            </a>
            
        </div>

        <ul class="footer-nav-container footernav">
            <li class="footer-nav-item contact-us">
                <a href="/contact/">Contact Us</a>
            </li>

            <li class="footer-nav-item advertise">
                <a href="/contact/?advertise">Advertise</a>
            </li>

            <li class="footer-nav-item jobs">
                <a href="/jobs">Jobs</a>
            </li>

            <li class="footer-nav-item archives">
                <a href="/archives/">Archives</a>
            </li>

            <li class="footer-nav-item newsletters">
                <a href="/newsletters/">Newsletters</a>
            </li>

            
            <li class="footer-nav-item masthead">
                <a href="https://www.blogto.com/masthead/">Masthead</a>
            </li>
            

            
            <li class="footer-nav-item iphone-app">
                <a href="https://itunes.apple.com/ca/app/blogto/id435310228?mt=8">iPhone App</a>
            </li>
            

            

            <li class="footer-nav-item terms-of-service">
                <a href="/termsofservice/">Terms of Service</a>
            </li>

            <li class="footer-nav-item privacy-policy">
                <a href="/privacy/">Privacy Policy</a>
            </li>

            
            <li class="footer-nav-item mobile-masthead mobile-view">
                <a href="https://www.blogto.com/masthead/">Masthead</a>
            </li>
            

            
            <li class="footer-nav-item mobile-iphone-app mobile-view">
                <a href="https://itunes.apple.com/ca/app/blogto/id435310228?mt=8">iPhone App</a>
            </li>
            

            
        </ul>

        <ul class="footer-nav-container footersubnav">
            <li class="footersubnav-item">
                <a class="footersubnav-item-link"
                   href="http://www.freshdaily.ca/">
                    ©2021 Freshdaily Inc.
                </a>
            </li>

            <li class="footersubnav-item terms-of-service">
                <a class="footersubnav-item-link"
                   href="/termsofservice/">
                    Terms of Service
                </a>
            </li>

            <li class="footersubnav-item privacy-policy">
                <a class="footersubnav-item-link"
                   href="/privacy/">
                    Privacy Policy
                </a>
            </li>

            <li class="footersubnav-item designcredit">
                <a class="footersubnav-item-link"
                   href="http://studiofunction.com" target="_blank">
                    Design by Studio Function
                </a>
            </li>
        </ul>
    </nav>
</footer>




<div class="blogto-sticky-banner">
    <div class="blogto-sticky-banner-wrapper">
        <div class="blogto-sticky-banner-advert-container-x-small">
            
    
        <div id="1029532/blogTOmobile320x50city"
             class="advert"
             style="min-height: 50px">
            <script type='text/javascript'>
                (function () {
                    var advert = {};
                    var screenTypes = [];
                    advert.id = "1029532/blogTOmobile320x50city";
                    advert.elementId = "1029532/blogTOmobile320x50city";
                    advert.width = 320;
                    advert.height = 50;
                    advert.boxType = "mobile_bottom";
                    
                        screenTypes.push("x-small");
                    
                        screenTypes.push("small-1");
                    
                    advert.screenTypes = screenTypes;

                    window.freshDaily.advertMap[advert.boxType] = advert;

                    window.freshDaily.preProcessors.push(function () {
                        window.freshDaily.AdvertManager.initAdvert(advert, googletag);
                    });
                })();
            </script>
        </div>
    


        </div>
        <div class="blogto-sticky-banner-advert-container-small">
            
    
        <div id="1029532/blogTOcitytakeover728x90tablet"
             class="advert"
             style="min-height: 90px">
            <script type='text/javascript'>
                (function () {
                    var advert = {};
                    var screenTypes = [];
                    advert.id = "1029532/blogTOcitytakeover728x90tablet";
                    advert.elementId = "1029532/blogTOcitytakeover728x90tablet";
                    advert.width = 728;
                    advert.height = 90;
                    advert.boxType = "tablet_bottom";
                    
                        screenTypes.push("small-2");
                    
                        screenTypes.push("small-1");
                    
                    advert.screenTypes = screenTypes;

                    window.freshDaily.advertMap[advert.boxType] = advert;

                    window.freshDaily.preProcessors.push(function () {
                        window.freshDaily.AdvertManager.initAdvert(advert, googletag);
                    });
                })();
            </script>
        </div>
    


        </div>
    </div>
    <script type="text/javascript">
        (function () {
            document.body.classList.add("sticky-banner-body");
        })();
    </script>
</div>



    <div id="login-dialog-container"></div>

    <div id="email-login-dialog-container"></div>

    <div id="reset-password-dialog-container"></div>

    <div id="calendar-dialog-container"></div>

    
    


<script type="text/javascript" src="https://static.blogto.com/static/dist/commons-chunk-bootstrap-7c9a51c9eb5eff5dd4e1.js" ></script>
<script type="text/javascript" src="https://static.blogto.com/static/dist/blogto-lib-b43b210d7e32a4672a9e.js" ></script>
<script type="text/javascript" src="https://static.blogto.com/static/dist/blogto-app-5965457091b8b342bfc2.js" ></script>


<script type="text/javascript" src="https://static.blogto.com/static/dist/article-detail-app-1d567eb05058d8c86de4.js" ></script>

<script type="text/javascript">
    (function () {
        var ArticleBookmarkData = window.freshDaily.ArticleBookmarkData;

        var sessionLogicList = [];
        sessionLogicList.push(
                {
                    "key": "bookmarkedArticleMap",
                    "callback": ArticleBookmarkData.fetchBookmarkedArticles
                });

        window.freshDaily.sessionLogicList = window.freshDaily.sessionLogicList.concat(sessionLogicList);
    })();
</script>




<script type="text/javascript">
    window.freshDaily.facebookPromise = new Promise(function (resolve, reject) {
        (function (d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s);
            js.id = id;
            js.src = "//connect.facebook.net/en_US/sdk.js";
            fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));

        window.fbAsyncInit = function () {
            FB.init({
                appId: "100616073343311",
                xfbml: true,
                version: "v2.5"
            });

            resolve();
        }
    });
</script>

<script type="text/javascript">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</script>

<script type="text/javascript">
    window.freshDaily.twitterPromise = new Promise(function (resolve, reject) {
        if(!window.twttr){
            window.twttr = (function (d, s, id) {
                var js, fjs = d.getElementsByTagName(s)[0],
                        t = window.twttr || {};
                if (d.getElementById(id)) return t;
                js = d.createElement(s);
                js.id = id;
                js.src = "https://platform.twitter.com/widgets.js";
                fjs.parentNode.insertBefore(js, fjs);

                t._e = [];
                t.ready = function (f) {
                    t._e.push(f);
                };

                return t;
            }(document, "script", "twitter-wjs"));

            window.twttr.ready(function (twttr){
                resolve(twttr);
            });
        } else {
            resolve(window.twttr);
        }
    });
</script>

<script type="text/javascript">
    window.SIGNUP_URL = '/accounts/newsletter/subscribe/';

    (function () {
        var AuthManager = window.freshDaily.AuthManager;
        var sessionPromise = AuthManager.initUserSession(window.freshDaily.sessionLogicList);
        window.freshDaily.sessionPromise = sessionPromise;
    })();
</script>




<script type="text/javascript">
    (function(){
        var isSlideShow;

        
        isSlideShow = false;
        

        var staticLatestArticlesLength = parseInt("8");
        var articleDetailListingsMapData = [];
        var articleDetailListingsLength = 0;

        window.freshDaily.Logger.debug(staticLatestArticlesLength);

        window.freshDaily.createArticleDetailApp(
            $,
            "7", "", 
            isSlideShow,
            staticLatestArticlesLength,
            articleDetailListingsLength,
            articleDetailListingsMapData,
            window.freshDaily.customArticleDetailPageReducerGenerators,
            "Police busted an illegal car meet-up in Oshawa with more than 300 people"
        );
    })();
</script>

</body>
</html>
